Cristina Alcantarilla
INFORMÁTICA & DISEÑADORA
Solución al error: E: Sub-process /usr/bin/dpkg returned an error code (1)

Es importante averiguar primero cual es el paquete que está generando el problema. Para eso abrimos una Terminal, escribimos sudo apt-get upgrade y cuando salga el error arriba mencionado, unos renglones antes va a aparecer cuál es el paquete con el que hay problemas, por ejemplo nombre-del-paquete.deb.

Para resolver el problema haremos lo siguiente:

1) Abrir un explorador de archivos (Nautilus, Pantheon, Nemo, Thunar, etc.) con privilegios de root: Alt+F2 (o desde una Terminal): gksu nautilus o gksu pantheon-files (en elementary OS) dependiendo tu explorador de archivos.

2) Ir a /var/lib/dpkg/info

3) Borrar todos los archivos que hagan referencia al paquete que genera el problema (nombre-del-paquete)

4) En una Terminal poner sudo apt-get update

Share Button

Deja un comentario